SIMCOM X Voice application

Suggestions, ideas and general discussion about JoinFS.
ATC Roo
Posts: 484
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Sat May 04, 2019 8:14 pm

Well I can see quite a few people now using SimCom X successfully.

I know people dont know what frequency others are using, so I would encourage people to use the Unicom frequency 122.800 when trying it out on their own.

As it's now working, I'm going to calm down on the updates.

I can see a few minor faults which I'm correcting one by one and will release updates with a number of issues corrected in each update.

Please let me know of any issues you find.
If I dont know about them, I cant fix them.

twodogzz
Posts: 3
Joined: Mon Feb 04, 2019 11:39 am

Re: SIMCOM X Voice application

Postby twodogzz » Fri May 10, 2019 4:23 am

ATC Roo wrote:If I dont know about them, I cant fix them.


Is this an expected behaviour?

Open SIMCOM X
Click on OFF
Repeating Message." Trying to connect...." "Checking...." "Found!"
The OFF button indicates red and stays OFF, Sim indicates Offline (ok sim not running), Voice indicates red "Offline". Mode indicates red "None".

In addition, clicking on the Window close "x" or the OFF button does nothing.
To close the SIMCOM X window I have to right click the taskbar icon and click Close Window.
SIMCOMX displays the message Powering Down and a Microsoft .NET Framework Unhandled exception message window.
I click on "Quit" in the .NET message window and both windows close.

I sent the log.txt file to you via PM.
Attachments
simcomX 2019-05-10 1417.JPG
Microsoft .NET Framework Unhandled exception message
simcomX 2019-05-10 1417.JPG (24.16 KiB) Viewed 632 times
simcomX 2019-05-10 1402.JPG
Trying to connect... Checking... Found!
simcomX 2019-05-10 1402.JPG (29.41 KiB) Viewed 632 times

ATC Roo
Posts: 484
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Fri May 10, 2019 3:44 pm

Thank you.

I think I know what that is.

I experimented with something a few days ago, which I'll change back shortly.

Using SimCom X by connecting to a sim before then, may fix it.

No app update needed.

davetfc
Posts: 6
Joined: Sun Jun 09, 2019 7:52 pm

Re: SIMCOM X Voice application

Postby davetfc » Fri Jun 14, 2019 5:20 pm

Hi,

I'm having some trouble getting SimCom X to work in X-Plane (version 11.34r1 - build 113400 64-bit). See following images.

Image 1 - This is the current settings being used in SimCom X

Config SimComX.jpg
Config SimComX.jpg (57.2 KiB) Viewed 312 times


Image 2 - When turning SimCom X on, it makes the connection to XP, but the COM1 channel frequency is not synchronizing correctly with the frequency set on the COM1 radio. In XP I've tuned the radio to Unicom 122.80, but in SimCom X the active frequency is shown as 121.800. Also when I switch the frequency in XP to 123.900 the active frequency in SimComX is not changed!

SimComX - XP11 - 1.jpg
SimComX - XP11 - 1.jpg (140.71 KiB) Viewed 312 times


Image 3 - After a while I see error messages in SimCom X, like "Error adding user!" and "Error Removing user!".

SimComX - XP11 - 2 - error adding user.jpg
SimComX - XP11 - 2 - error adding user.jpg (142.17 KiB) Viewed 312 times


I'm currently using version 2.0.3.8 64 bit of XPUIPC. Also in the firewall, I've forwarded port 9988 UDP to the local IP of the PC running XP and SimCom X.

What am I missing here? Thanks!

Kind regards,

Dave
Belgium

ATC Roo
Posts: 484
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Fri Jun 14, 2019 8:56 pm

Hi Dave.

Thanks for the post.

Can you send me your log.txt file located in ProgramFiles(x86)/simcomx folder.

davetfc
Posts: 6
Joined: Sun Jun 09, 2019 7:52 pm

Re: SIMCOM X Voice application

Postby davetfc » Fri Jun 14, 2019 9:56 pm

Ah yes. Forgot about that file. Here attached as a zip file.

log.zip
(80.31 KiB) Downloaded 12 times


Kind regards,

Dave
Belgium

ATC Roo
Posts: 484
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Sat Jun 15, 2019 9:55 am

Thanks Dave.

I think I see the issue(s) but I'm not going to have time to fix them for a few days.
It looks like it's the "." "," separator that is used with certain language packs.

In some parts of the world a lat lon would be
52.123456 3.123456
in others...
52,123556 3,123456

I couldn't see in the log but this might be happening with the frequency too.

The distance option also wont work for you at the moment.

With distance and autoswitch unticked you'll be able to use simcom x until I can get an update out.

davetfc
Posts: 6
Joined: Sun Jun 09, 2019 7:52 pm

Re: SIMCOM X Voice application

Postby davetfc » Sat Jun 15, 2019 3:02 pm

Hi,

Thanks for your reply. So I modified the configuration with your tips and I'm also setting the com frequency manually in SimComX.

SimComX - config modified.jpg
SimComX - config modified.jpg (58.14 KiB) Viewed 301 times


I'm still getting the "Error adding user!" messages though.

SimComX - Error msgs.jpg
SimComX - Error msgs.jpg (49.91 KiB) Viewed 301 times


I'm also attaching the latest log files.

log1.zip
(1.41 KiB) Downloaded 12 times


Any suggestions as to how I can resolve this? Thanks!

Kind regards

Dave
Belgium

ATC Roo
Posts: 484
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Sat Jun 15, 2019 4:04 pm

Dont worry about that error.
It relates to a backup server on the backend.

Something I'm not worried about at the moment and will look into a some point.

I can see that you did connect successfully.

davetfc
Posts: 6
Joined: Sun Jun 09, 2019 7:52 pm

Re: SIMCOM X Voice application

Postby davetfc » Sat Jun 15, 2019 6:16 pm

OK. Thanks for the information!

Kind regards,

Dave
Belgium


Return to “Discussion”