X-Plane Pilots - Please Comment

Report problems with JoinFS.
User avatar
Dan-TXHills
Posts: 107
Joined: Wed Oct 12, 2016 5:40 pm
Location: South Texas, USA
Contact:

X-Plane Pilots - Please Comment

Postby Dan-TXHills » Mon Jan 14, 2019 8:58 pm

Not an X-Plane flyer myself but I am reporting some issues between two flying on X-Plane and between me (on P3D v4.4) and an X-Plane flyier.

Two of our X-Plane pilots encountered some problems - Cessna 172 G1000 (both in this plane)
- sharing all controls: pilot taking over could not control anything AND
- when that person leaves the aircraft they joined it would lock of the controls of the aircraft they left
- if one joined a running aircraft from their 'cold and dark' aircraft it would cause the screen of the person they joined to go blank
- If JoinFS is running before an aircraft is loaded X-Plane crashes when you try to load an airplane; you have to load in at an airport before starting JoinFS

I was able to take over controls from the X-Plane pilot using P3D, both in the standard 'steam gauge' C172. When I gave the X-Plane pilot the controls of my aircraft (P3D v4.4) I could not take the controls back - the controls were unresponsive on my end. Same thing if the X-Plane pilot left my aircraft entirely - my controls did not respond, had to reload the aircraft.

User avatar
Peter
Site Admin
Posts: 1441
Joined: Fri Sep 23, 2016 8:51 am

Re: X-Plane Pilots - Please Comment

Postby Peter » Mon Jan 14, 2019 10:15 pm

Hi Dan,

were you all on the same version of JoinFS?

Peter

User avatar
Dan-TXHills
Posts: 107
Joined: Wed Oct 12, 2016 5:40 pm
Location: South Texas, USA
Contact:

Re: X-Plane Pilots - Please Comment

Postby Dan-TXHills » Mon Jan 14, 2019 11:09 pm

Yes - v1.4.20. They had not tried shared-cockpit on previous versions.

Dan

xusmcxjasonx
Posts: 1
Joined: Wed Jan 16, 2019 5:54 pm

Re: X-Plane Pilots - Please Comment

Postby xusmcxjasonx » Wed Jan 16, 2019 6:01 pm

Peter,
Being a X-Plane pilot myself I have noticed there was a payware addon for shared cockpit.

- The way it works is by syncing the dataref's from one computer to another PC. The only way to do this was if we was using a VPN i.e hamachi.
Maybe we could try to see how that works.

- I am all ears to help develop this since there is a lot of people switching to X-Plane.

Thanks,

Jason

Loek
Posts: 4
Joined: Tue Jan 16, 2018 4:04 pm

Re: X-Plane Pilots - Please Comment

Postby Loek » Thu Jan 17, 2019 11:50 am

Yesterday (20190116) I was flying the same airplane as my friend (both on X-Plane 11.30 and JoinFS 1.4.20). As soon as my friend connected my screen became ‘white’. The same would happen when my friend connects first and I second. As a result, both of our screens are ‘white’. We flew earlier (before 11.30 and on 1.4.18) the same airplane. The only issue then was that the liveries changed as soon as number 2 connected. But we could fly without a problem. Changing back to 1.4.18 (but with 11.30) did not improve the situation. We tried multiple aircraft (all X-Plane default or payware aircraft).
The only work-around we found yesterday was replacing (in JoinFS) the aircraft of the other player by another type. We needed to make that change both. When looking out of the window I could see myself in the correct aircraft while my friend would be in the replacement aircraft. When he was looking outside his window, he would see the correct aircraft for himself, but he would see me in the replacement aircraft.
One way or the other another issue is connected to this: when the screens become ‘white’ the JoinFS information immediately indicated that our aircrafts (in X-Plane on the same airport) were over 4000 nm apart.
It would be great when these issues could be resolved.
Thanks!
Loek.

User avatar
Peter
Site Admin
Posts: 1441
Joined: Fri Sep 23, 2016 8:51 am

Re: X-Plane Pilots - Please Comment

Postby Peter » Thu Jan 17, 2019 1:01 pm

Hi Loek,

At the moment it looks like there are issues related to version 11.30 of X-Plane. The screen turning white is a new one to me, but there are also issues where the 172 G1000 instrument goes dark, and other aircraft, like the Bell 407 where instruments go gray as soon as another instance of your own aircraft in injected into X-Plane. This does point to a bug in X-Plane 11.30, as indicated by going back to 1.4.18 of JoinFS didn't resolve the problem.

My suspicions are that this is related to the large scale changes currently being made in X-Plane as they change from OpenGL to Vulkan rendering engine. On the plus side, due to these changes there is a new drawing interface for plugins, so I'm going to try this out and hopefully that will fix these issues.

Peter

Loek
Posts: 4
Joined: Tue Jan 16, 2018 4:04 pm

Re: X-Plane Pilots - Please Comment

Postby Loek » Thu Jan 17, 2019 11:42 pm

Hi Peter,
Thank you for your immediate reply.
I agree the issue must be 11.30 related. I cannot judge whether this is a bug or a consequence of a structural change in X-Plane, but you probably can.
I hope this will be resolved one way or the other. Thanks for providing a great piece of software.
Loek.


Return to “Bugs”