ATC with JOINFS

Suggestions, ideas and general discussion about JoinFS.
User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: ATC with JOINFS

Postby Peter » Sat Feb 02, 2019 9:14 pm

ATC Roo wrote:Are you using the lastest stable version Neville?
There is a problem with the whazzup in the latest stable v1.4.20.


Yes, it could be that. That problem was dependent on being connected to the simulator I think, but it's fixed in the next version. New stable version should be available Monday morning.

Peter

ATC Roo
Posts: 540
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: ATC with JOINFS

Postby ATC Roo » Sun Feb 03, 2019 10:03 am

I'll also try and get on tonight, but can't promise.

I successfully controlled last night using the latest test version .25 and the Global option ticked.
This worked while testing with Peter last week too.

In the JoinFS settings I ticked the whazzup.txt and whazzup global users but left the AI unticked.

I didn't connect to a SIM or hub, I only selected the Global option on the main screen in JoinFS.
This showed everybody else that had ticked the Global option.

SIMCOM X now seems mostly stable and I did notice a few issues in ESJFS last night, so I'll rewrite the Euroscope tool ESJFS shortly and try and make it a little more user friendly.

brendantdj
Posts: 2
Joined: Sun Sep 01, 2019 1:15 pm

Re: ATC with JOINFS

Postby brendantdj » Sun Sep 01, 2019 1:40 pm

Co-ordination between ATC is possible on Euroscope by using the proxy feature. We were using this but the problem is that there is no callsign for the aircraft, Euroscope will identify craft using that.

Could you set up ESJFS so it sets the callsign on the flight plan to either the crafts callsign/tail number? This would allow our controllers to control aircraft without having to either get the user to import a flight plan on FSX (which has severely out of date navaids and is a pain to get working) or the ATC having to copy/pasta the flight plan from our flight strips page.

All we need is the callsign on the flight plan to be updated automatically so Euroscope tracks the craft. It works perfectly fine when a callsign is set, but you can't set a callsign it only appears when a user files a flight plan (sometimes, kind of unreliable).

Tl;dr
Euroscope needs to have a callsign set on the flight plan to track changes on that aircraft. If you can set the callsign (on the flight plan) then you can use Euroscope with multiple controllers/instances. Euroscope doesn't let you set the callsign

brendantdj
Posts: 2
Joined: Sun Sep 01, 2019 1:15 pm

Re: ATC with JOINFS

Postby brendantdj » Sun Sep 01, 2019 8:43 pm

The callsign is not synced with Euroscope (on the flight plan).

This is important as it allows Euroscope to track an a/c between clients (with the proxy) and is used to identify most information. Information like the squawk may remain but the entire flight plan would be lost.

We can solve this by getting our pilots to file any plan, doesn't have to be valid and the callsign will appear (sometimes) letting our atc all see the same information about a craft.

This could be solved by syncing the flight plan callsign with the one reported by FSUIPC, FSX etc.

Is it possible to do this or even a feature in the future?

ATC Roo
Posts: 540
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: ATC with JOINFS

Postby ATC Roo » Mon Sep 02, 2019 9:25 pm

Hi Brendantdj,

I'll be honest I'm not totally sure what you mean by this?

I'll be looking at the code in the near future, I've just got a major upgrade to simcom X to box off first.

A little bit of information from my side (off the top of my head)...

ESJFS gets the data from either the JoinFS whazzup file, FSX/P3D via SimConnect or through FSUIPC/XUIPC.

It puts together what Euroscope needs to see for a flight plan from the data gained and sends it to EuroScope.

The callsign is one of the bits of data it gains.
The arrival and departure airports are another.
So see if they are set and showing in the JFS whazzup file or in the ESJFS debug window.

The only instance of no callsign that I know of is when FSUIPC is used to gain the data.
I'm not sure why this happens but it only happens when FSUIPC is used.

When this does occur I told ESJFS to use the aircrafts squawk code instead.
This is so aircraft can still be identified and also adds realism as most Radar scopes I've seen show aircraft by squawk and not by callsign (although they can be code callsigned..., opening up a can of worms and going off topic....).

I'm also not sure how you are initiating handovers?
I've not written anything to do that and each EuroScope client is essentially not talking to each other.

As far as I'm aware (with the exception of area), radar handovers are normally conducted over the phone Controller to Controller.
Example: (Hello Edinburgh Radar its Glasgow Radar.
Do you see that 1234 squawk east of DeanCross tracking 090 degrees? Well that's GABCD, inbound to you....).

If you can pinpoint the issue a bit more (does it only happen using FSUIPC?) and let me know how your conducting your handovers(do you get a message in EuroScope when somebody tries to handover?) I'll have a look into it.

Roo

otomas
Posts: 3
Joined: Wed Feb 19, 2020 11:14 am

Re: ATC with JOINFS

Postby otomas » Wed Feb 19, 2020 11:25 am

Hi all
i have joined JoinFs and im trying to run ESJFS1018 but it don open
in windows event i see 2 entries:
1 :
Aplicación: ESJFS2018.exe
Versión de Framework: v4.0.30319
Descripción: el proceso terminó debido a una excepción no controlada.
Información de la excepción: System.IO.FileLoadException
en ESJFS2018.Form1..ctor()
en ESJFS2018.Program.Main()
2:
Nombre de la aplicación con errores: ESJFS2018.exe, versión: 2.1.0.1, marca de tiempo: 0x5c419704
Nombre del módulo con errores: KERNELBASE.dll, versión: 10.0.18362.628, marca de tiempo: 0x54734dee
Código de excepción: 0xe0434352
Desplazamiento de errores: 0x00113db2
Identificador del proceso con errores: 0x2e40
Hora de inicio de la aplicación con errores: 0x01d5e714d0c8e008
Ruta de acceso de la aplicación con errores: I:\JoinFS\ESJFS2018.exe
Ruta de acceso del módulo con errores: C:\WINDOWS\System32\KERNELBASE.dll
Identificador del informe: ecc7b120-1da0-4de0-9e35-97ade346e43a
Nombre completo del paquete con errores:
Identificador de aplicación relativa del paquete con errores:

i have read all related topic with with subject without success :cry:

i have windows 10 (1903 updated)
i m devellopper and i have Visual studio profesionnal (2010,2012,2015,2017,2019)

i have launched with admin privilege
i have moved all the files to anothre place ( out of windows structure dir)

any idea?

thank all.


Return to “Discussion”