[X-Plane 11.3x] Friend's plane not visible in Aircraft List

Any questions regarding JoinFS.
Cumulonimbus
Posts: 4
Joined: Thu Apr 04, 2019 8:46 am

[X-Plane 11.3x] Friend's plane not visible in Aircraft List

Postby Cumulonimbus » Mon Apr 08, 2019 11:23 am

Hello all,

a few days ago I had my first multiplayer session under X-Plane with JoinFS and it worked quite good! I saw my friend's plane, he saw mine, everything fine (nice line ;)).
But: We tried to share one cockpit and couldn't get this to work. I did it as the manual described (set permissions), but he couldn't join my cockpit. Also, in the list of aircrafts only my aircraft showed up (both on his side and on my side). So it was not possible to test, if I could join his cockpit.

Does anyone have a clue what I could try to get this feature to work? I suspect that the absence of his plane in the list has to do something with this issue. What did we do wrong?
Anyway, flying together with JoinFS worked like a charm!

Thanks for help!

Greets
Cb

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: [X-Plane 11.3x] Friend's plane not visible in Aircraft List

Postby Peter » Mon Apr 08, 2019 12:19 pm

Hi,

when you enabled the permissions, did you also hand over the controls? There is a bug at the moment where if you tick all the boxes it doesn't work properly. Try just Allow Cockpit Entry only, and they should be able to join you.

When testing out any activity, I generally check the user list first to make sure connection is okay. Then the aircraft list to make sure the aircraft are present as expected and are being injected correctly, before doing the Enter Cockpit part.

Peter

Cumulonimbus
Posts: 4
Joined: Thu Apr 04, 2019 8:46 am

Re: [X-Plane 11.3x] Friend's plane not visible in Aircraft List

Postby Cumulonimbus » Mon Apr 08, 2019 1:29 pm

Peter,

I handed over the controls, yes. But I didn't tick all the boxes. It was only cockpit entry and flight controls (showing 'CF').
Ok, next time we'll try it without the controls.

But what to do, if only one of our planes is showing in the aircraft list? As I said, I suspect this was the issue which led to the problem of being not able to join in the cockpit.
The connection was obviously ok, network and simulator buttons all green. Aircrafts showing up in the sim. Users showing up in the user list.
Aircraft list showed only me on my and on my friend's side. Could he have missed some settings or some ticks?

Thanks
Timo


Return to “Queries”