Page 1 of 1

Strange Loss of Function

Posted: Wed Feb 20, 2019 9:54 pm
by Dan-TXHills
About a week ago I installed v1.4.25 to help a couple of folks verify their connecti0n was working properly. No issues - we each saw each other, I could see a long list of users when connected to the Global hub. Left this running for a few hours so others could test as needed but did not check back - closed everything down at that point. Simulator in use is P3D v4.4 and has never had an issue with JoinFS prior to that described below.

Full disclosure: Windows (Win10) did at least two updates and caused my computer to act strangely - e.g., it took at least 30 minutes of 'black screen' for the computer to start the first time after the last update. Since then all appears to be working normally (except JoinFS).

I started the sim and opened JoinFS v1.4.25, connected to the Global hub and - nothing. Could not see anyone else on the User list except myself and my listing was in red to indicate I was not connected (in spite of both the Simulator and Network lights were green). Uninstalled using Revo (so that also removed the registry entries and other files) and re-installed v1.4.25 from a fresh download - started up JoinFS and got the 'scan for models' and model matching (along with nothing in the Settings other than the default info) so I knew that, at least to the extent of my ability to remove everything, this was a fresh install. Did the model scan, etc., connected to the Global hub and -- same result. I was the only one on the list and the indication was that I was not connected.

Gets even stranger -
- On a different machine, same LAN and internet connection: v1.4.25 appears to work normally - I see multiple people connected on the Global Hub
- On the same machine as the one described initially with v1.4.25 suddenly not working, Test v1.4.27 works fine.

I suspect once again that malware known as Windows 10 and the incessant updates has again messed things up but I cannot figure out how.



To verify that my other computer - running Windows 7 (not the one with the problem described above) still worked I fired up JoinFS v1.4.25 (no sim running) - did not realize that I had left it running, went downstairs to my "flying" computer and lo and behold it appeared that I was connected and I could see others on the Global hub. Back upstairs - shut down JoinFS on the other computer, went back to my flying computer and refreshed - back to only me, showing me in red, not connected. NB: JoinFS WAS running (with FSX SE running) on the other computer at the time I installed (and successfully connected for others to test) v1.4.25 on my 'flying' computer. So - maybe not a Win10 update issue at all, although personally I think they still deserve the 'dis even if on this particular occasion it is not their fault!

Re: Strange Loss of Function

Posted: Wed Feb 20, 2019 10:37 pm
by Peter
All sounds a bit odd, Dan. Could be related to the recent connection issues. I just made some fixes today and noticed that messages might be going to the wrong ports, so in your case if you have several machines running JoinFS behind the same router it's possible that messages were going to the wrong machines.

See what happens with 1.4.28 which I'll be putting down tomorrow. I'll make this the new stable version as soon as possible to try and get everybody up to the new version.


Re: Strange Loss of Function

Posted: Wed Feb 20, 2019 11:32 pm
by Dan-TXHills
Thanks Peter.

What seemed very odd to me was that on the machine that JoinFS did not work if no other JoinFS applications were running on my LAN but it did work when I started JoinFS on a second computer. Will watch for the latest version. Test v1.4.27 does work (and I was able to connect with others using v1.4.25) so I am optimistic that things will get straighten out with the next update.