V1.4.25 X-Plane can't connect to Simulator (Red or Orange)

Report problems with JoinFS.
LarryJ
Posts: 7
Joined: Tue Jan 29, 2019 6:39 pm

V1.4.25 X-Plane can't connect to Simulator (Red or Orange)

Postby LarryJ » Mon Feb 04, 2019 11:41 pm

On V1.4.20, I could connect to x-plane and received quick green "Simulator" button color. But on the new V1.4.25, I can never turn the button green. Sending a screen shot with various diagnostics. Another odd item, the x-plane check box form Enable/Disable Plugins refuses to go away by vigoro8s clicking.
Attachments
Capture.JPG
Capture.JPG (206.27 KiB) Viewed 302 times

LarryJ
Posts: 7
Joined: Tue Jan 29, 2019 6:39 pm

Re: V1.4.25 X-Plane can't connect to Simulator (Red or Orange)

Postby LarryJ » Tue Feb 05, 2019 12:05 am

Forgot to add that x-plane is V 11.31r1 and I have windows 10 home fully updated installed in a rather high end system.

Larry
Attachments
system.jpg
system.jpg (54.21 KiB) Viewed 301 times

LarryJ
Posts: 7
Joined: Tue Jan 29, 2019 6:39 pm

Re: V1.4.25 X-Plane can't connect to Simulator (Red or Orange)

Postby LarryJ » Tue Feb 05, 2019 1:44 am

Also Peter would you please answer these questions I have after reading various forms and the JoinFS manual

1. In X-Plane I have to have more than (upto 15) AI aircraft specified so that I have at least one AI aircraft for each aircraft (X-plane,FSX P3D) that I am "flying" with in joinFS? So if I have 4 AI craft specified in X-Plane and am flying with a group that has five, I won't "see" a representation of the fifth craft?

2. In X-Plane, I can not set my AI aircraft to say a Cessna 172 if someone else in the group is using "flying" that aircraft type. As a precaution I've set all my AI craft to the Laminar ASK flying wing ultra light. So far without any help.

3. In the JoinFS monitor, I see over and over, simconnect not installed. If I install the provided plugin (I clicked on Install joinFS Plugin settings button) and JoinFS shows up in X-Planes "plugin enable disable" admin form, I shouldn't need simconnect or for that matter XPUIPC, correct?

4. Can XPUIPC be installed (via having its directory in the resources/plugins directory of X-Plane) at the same time as I am using JoinFS? (Not actually using XPUIPC via Sqawkbox say but it's there and shows up enabled in the X-Plane Settings "Plugin Enable/Disable" form) OK to leave enabled and installed?

5 I expect that in the JoinFS settings form, the ip address of 127.0.0.1 is identical entering my X-Plane's computer's statically assigned LAN ip address like 192.168.1.101? Any reason to favor one over the other?

6. My internet ISP delivers connectivity via wireless 5GHz radio transceivers. At his headquarters, there is at least 2 maybe 3 Net Work Translations NATs (from fiber backbone to private ip, for example) and I have one here locally in my router (private ip off the wireless radio to private ip on my local area network. Do I have to forward port 6112 if I connect to a server but I am not setting up my JoinFS to become a server?

Thank you Larry

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: V1.4.25 X-Plane can't connect to Simulator (Red or Orange)

Postby Peter » Tue Feb 05, 2019 10:22 am

Hi Larry,

you probably need to reinstall the plugin from the JoinFS settings window. Make sure X-Plane isn't running when you install it. I'll look at doing a notification when a reinstall is required.

To answer your other questions:

1. Correct

3. Correct. It's not supposed to repeat over and over, and it's not a warning, it's just informational, you don't need it. So I'll look at changing that.

4. I believe so.

5. No.

6. No. However, some routers can be stricter than others. So you should only try setting up port forwarding if you appear to have issues connecting to any session.

Hope that helps.

Peter

LarryJ
Posts: 7
Joined: Tue Jan 29, 2019 6:39 pm

Re-install Fixed Problem: Now Connected to Simulator

Postby LarryJ » Tue Feb 05, 2019 3:35 pm

Peter:
Thanks for your quick replie(s)! Indeed reinstalling the plugin allows me to connect to the simulator. So for benefit of someone else with the same problem, here's my method to reinstall:

1. With X-Plane not running (check in the task list if you have any doubt), bring up windows file explorer and browse to the x-plane folder containing the plugins. My location is , for example, C:\Users\lj\X-Plane 11\Resources\plugins\ , In this directory, you should find a subdirectory labeled JoinFS. Delete this directory (In my case, the directory is C:\Users\lj\X-Plane 11\Resources\plugins\JoinFS)

2. While observing the Resources directory in File Explorer, invoke JoinFS (mine lives at "C:\Program Files (x86)\JoinFS\JoinFS.exe"). In JoinFS, click File > Settings. Verify that you have a check by "X-Plane - Enable" and that your X-Plane's PC ip address is entered. Use 127.0.0.1 if you don't know it. Then click on Install Plugin. In Windows File Explorer, you should see that a directory JoinFS was immediately created. On my system it was C:\Users\lj\X-Plane 11\Resources\plugins\JoinFS. In the directory JoinFS should be two sub directories "32" and "64". In the subdirectory "64", should be one X-Plane plugin file named Win.xpl. At this date (Feb 5 2019) Win.xpl has a date of 1/14/2019. That date could change as Peter continues implementing X-Plane.

3. Then close JoinFS. Invoke X-Plane and observe that in Plugins > Plugin Admin > Plugin Information, you have an entry showing "Join FS (Enabled)" With X-Plane running, invoke (start) JoinFS again. You should be rewarded with a Green Simulator button.

4. AT this time, I found the only way to get the X-Plane window "Plugin Information" to disappear is to restart X-Plane. Bug in X-Plane maybe?

Larry

LarryJ
Posts: 7
Joined: Tue Jan 29, 2019 6:39 pm

Re: V1.4.25 X-Plane can't connect to Simulator (Red or Orange)

Postby LarryJ » Tue Feb 05, 2019 3:39 pm

Peter:

Follow up on question #2: Is the model collision problem that I read about still valid. Can I "fly" the Laminar Research 172SP and someone else with X-Plane in the session also fly the same LR 172SP?

Again thanks for your help. I clicked on your donate button. Hope you find the means to continue development and support for JoinFS. It really enhances my enjoyment of X-Plane and Flight sim in general.

Larry

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: V1.4.25 X-Plane can't connect to Simulator (Red or Orange)

Postby Peter » Tue Feb 05, 2019 7:30 pm

Thanks, Larry. Very much appreciated.

The issue of having another aircraft of the same type is still a problem in X-Plane I believe. I think it might only affect he G1000 version. You can avoid the problem simply by substituting that model for something similar but not the exact same aircraft type as the one you're flying. Once I've changed over to using CSL objects this should no longer be a problem.

Peter


Return to “Bugs”