Greyed out Screens after connecting to JoinFS in XPlane 11

Report problems with JoinFS.
Dave-W
Posts: 2
Joined: Tue Dec 12, 2017 11:59 am

Greyed out Screens after connecting to JoinFS in XPlane 11

Postby Dave-W » Sat Jan 12, 2019 10:22 pm

Hi Peter
Friend & I tried to go online this evening using X Plane 11 Ver 11.30. Both aircraft show on strip and in LittleNavmap so connection is there, however both aircraft suffer internal instrument screens being greyed out. Also intermittent greyed out external scenery too. Was OK prior 11.30. Have downloaded & installed Join FS 1.4.20. Still same issues prevail. Any ideas please.

User avatar
Peter
Site Admin
Posts: 1457
Joined: Fri Sep 23, 2016 8:51 am

Re: Greyed out Screens after connecting to JoinFS in XPlane 11

Postby Peter » Sat Jan 12, 2019 10:28 pm

Hi,

I've also seen this in version 11.30 of X-Plane. It seemed to be when the other aircraft was of the same type as your own. Could you confirm that? Looks like a bug in X-Plane at the moment as it doesn't like having a duplicate aircraft in the scene. You could try substituting the aircraft for something else in the JoinFS aircraft list. See what happens as you change it.

Peter

Dave-W
Posts: 2
Joined: Tue Dec 12, 2017 11:59 am

Re: Greyed out Screens after connecting to JoinFS in XPlane 11

Postby Dave-W » Sun Jan 13, 2019 4:43 pm

Hi Peter
Yes the other aircraft was the same as mine, both were Aerobask Epic 1000. We will try substituting the aircraft in JoinFS as you suggest.

John F
Posts: 17
Joined: Mon Dec 11, 2017 2:45 pm

Re: Greyed out Screens after connecting to JoinFS in XPlane 11

Postby John F » Tue Jan 15, 2019 2:53 pm

Hi Peter,

Further to above: our problem continues.

Last night we both flew different Laminar aircraft as requested (Baron and Cessna). A little while later my friend changed to an Aerobast aircraft. At take off we both could see each on both Little Navmap and from the cockpit. However after a few minutes I noticed that my friend had vanished from LittleNavmap.

However all was still fine with regard to the aformentioned greyed out instrument issue: so we kept on flying. Then I noticed the Simulator box had turned red. We had to resort to trying 3 diferent servers until we managed to get things right and see each other again. (We ended up using Digital Themepark) Then after a short while my instruments once more greyed out.

I would add that my Friend is running Win 7 and myself Win 10

In summary we manged to retrieve the situation by trying different servers but this did not prevent the greyed out instruments from re-appearing on my aircraft (my friends aircraft was not affecter)

Does this help you? Thanks

User avatar
Peter
Site Admin
Posts: 1457
Joined: Fri Sep 23, 2016 8:51 am

Re: Greyed out Screens after connecting to JoinFS in XPlane 11

Postby Peter » Tue Jan 15, 2019 3:06 pm

Hi John,

The JoinFS/X-Plane connection is a little fragile at the moment. I'll see if I can tighten that up.

It's interesting that your friend didn't have the grayed out instrument problem when you did. Is he on the same version of X-Plane (i.e. version 11.30?)

Peter

John F
Posts: 17
Joined: Mon Dec 11, 2017 2:45 pm

Re: Greyed out Screens after connecting to JoinFS in XPlane 11

Postby John F » Tue Jan 15, 2019 3:35 pm

Hi Peter

Yes he is

John F
Posts: 17
Joined: Mon Dec 11, 2017 2:45 pm

Re: Greyed out Screens after connecting to JoinFS in XPlane 11

Postby John F » Sat Jan 19, 2019 9:44 am

Hi Peter,

Tried another flight last night with a friend, but again with the same issues. We spent some time swapping aircraft to try to get some answers. Started out with Laminar and Payware (Epic 1000) We then changed to both flying Laminar. There was period when everything was working fine, but then by green simulator box turned red and my instruments greyed out.

We then tried substituting aircraft, but I don't think either of use relly knew what we were doing there.

Is it an aircraft selection issue do you think? (I seem to recall that that was an issue for me some time ago) We can both get the 2 greens individually but the problems described occur when we both get online.

We also wondered whether the problem lie with the selected hub? Selection different hubs does seem to exhibit some differences. On my PC the Simulator box stayed green for a while but then always turned red after a minute or two.

Does this help you any further? Thanks

User avatar
Peter
Site Admin
Posts: 1457
Joined: Fri Sep 23, 2016 8:51 am

Re: Greyed out Screens after connecting to JoinFS in XPlane 11

Postby Peter » Sat Jan 19, 2019 10:24 am

Thanks, John.

JoinFS doesn't do any rendering in X-Plane, all it does is load an aircraft into the first AI slot of the flight configuration and then moves that aircraft. All the drawing and everything else is done by X-Plane. There's currently a lot of rendering changes going on in X-Plane so I imagine it's something to do with that.

The problem can be circumvented though if I use CSL objects instead of the AI aircraft slots.

Peter

User avatar
Grumpy
Posts: 89
Joined: Mon Oct 10, 2016 2:30 am

Re: Greyed out Screens after connecting to JoinFS in XPlane 11

Postby Grumpy » Mon Jan 21, 2019 8:21 am

Hi, Peter.

X Plane 11.30 flying Yesterday. JFS 1.4.20
Raymond and I were both flying the default Cessna 172, and doing the Shared Cockpit thing. My gps system had grey screens
Interestingly, the popup gps worked flawlessly. No matter WHO shared, it was me that had the grey screen. We could not discover an answer


In todays flight.
We loaded the 1.4.23 Test version, on our server, as the hub, and we all 6 of us, ran 23 as well.
Very mixed results Most were FSX and Tom n I were XP1130. At no point could everybody see all participants. We changed back to JFS 20, and things nearly improved. The XP users could only see half the FSX users, but at no stage could we get 100% visibility. We tried all combinations, checked and rechecked the JFS settings, to no avail. checked, unchecked the XP plugin, no difference to anybody.

One suggestion. The xp plug-in should be built-in to JFS, I never un-check the plug-in when flying FSX and I cannot detect any adverse results.
The fewer things the user has to do, to achieve functionality, the better.

Regards.....

User avatar
Peter
Site Admin
Posts: 1457
Joined: Fri Sep 23, 2016 8:51 am

Re: Greyed out Screens after connecting to JoinFS in XPlane 11

Postby Peter » Mon Jan 21, 2019 9:52 am

With version 1.4.23, do you mean that you couldn't see other users in the JoinFS User list or in the simulator? I just joined your hub and seemed to have a good connection to all other users in the user list.

Peter


Return to “Bugs”