1.4.8 Crashes with a FileNotFound error

Report problems with JoinFS.
picnic
Posts: 36
Joined: Tue Apr 04, 2017 8:19 am

1.4.8 Crashes with a FileNotFound error

Postby picnic » Sat Feb 03, 2018 11:49 am

Just tried upgrading my server to 1.4.8 but when I run it the joinFS dialog appears briefly then Window's tells me it's stopped working.

Event viewer reports

Code: Select all

Problem signature:
P1: joinfs.exe
P2: 1.0.0.0
P3: 5a704119
P4: JoinFS
P5: 1.0.0.0
P6: 5a704119
P7: 11e
P8: 1d
P9: System.IO.FileNotFoundException
P10:

I also have 1.4.3 stable on this machine and that runs fine. Being a 'server' there in no FS installed. Is this something I can fix?

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: 1.4.8 Crashes with a FileNotFound error

Postby Peter » Sat Feb 03, 2018 2:19 pm

That error message gives a hint at the problem but isn't quite enough information.

Was there a button to show more details of the crash? If not, you could try opening the Windows Event Viewer and finding the Error in the Application log. Hopefully there will be some more detail there.

Peter

picnic
Posts: 36
Joined: Tue Apr 04, 2017 8:19 am

Re: 1.4.8 Crashes with a FileNotFound error

Postby picnic » Sat Feb 03, 2018 4:20 pm

Sadly no Show More button. Event Viewer essentially just has what I've already reported, the XML file includes data about Windows and the computer but no file names. The Event Viewer link to a file in ProgramData doesn't exist. I've just noticed that the report is made multiple times as if there are several files not accessible.

Where does the test version store its files, I have an appdata/local/joinFS but no appdata/local/joinFS (test) - should that exist?

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: 1.4.8 Crashes with a FileNotFound error

Postby Peter » Sat Feb 03, 2018 4:31 pm

Test version uses the same files.

Could you run the stable version. Enable logging to a file. Then run the test version. After it crashes, look at the log - current file and post the details, thanks.

Peter

User avatar
spokes2112
Posts: 39
Joined: Wed Dec 21, 2016 3:05 am
Location: KGRB

Re: 1.4.8 Crashes with a FileNotFound error

Postby spokes2112 » Sat Feb 03, 2018 8:09 pm

Peter,

We have a gent that "Had" the same problem.
Going thru the 1.4.3 test run, logging, then back to point 8 pretty much let us know what was up..
A simconnect reinstall (all of them except Russian) from the "redist" took care of it.


Join FS Log -
03/02/2018 20:29:05.058 Started
03/02/2018 20:29:05.079 SimConnect 10.0.61259.0 not installed.
03/02/2018 20:29:05.487 No such host is known
03/02/2018 20:29:15.084 SimConnect 10.0.61259.0 not installed.
03/02/2018 20:30:32.466 Disconnected from simulator

Windows Log -
Log Name: Application
Source: Windows Error Reporting
Date: 03/02/2018 20:18:31
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: DESKTOP-GNUMERR
Description:
Fault bucket 1366725810301173237, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: joinfs.exe
P2: 1.0.0.0
P3: 5a704119
P4: JoinFS
P5: 1.0.0.0
P6: 5a704119
P7: 11e
P8: 1d
P9: System.IO.FileNotFoundException
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER70D6.tmp.mdmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER71C1.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER71CF.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER71EF.tmp.txt
\\?\C:\Users\DESKTOP\AppData\Local\Temp\WER7DD8.tmp.WERDataCollect

picnic
Posts: 36
Joined: Tue Apr 04, 2017 8:19 am

Re: 1.4.8 Crashes with a FileNotFound error

Postby picnic » Sat Feb 03, 2018 9:19 pm

Peter wrote:Could you run the stable version. Enable logging to a file. Then run the test version. After it crashes, look at the log - current file and post the details, thanks.
Done that, in fact turned on detailed logging too. File contains one line

Code: Select all

03/02/2018 21:17:11.349 Started

That's it I'm afraid.

EDIT: Just tried renaming the folder and 1.4.8 creates a new folder and a log file in there. Where are the settings saved? Is this in the Registry cos it knew to create the log file.

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: 1.4.8 Crashes with a FileNotFound error

Postby Peter » Sat Feb 03, 2018 9:56 pm

Settings are saved in the registry. Try searching for a JoinFS and you should find them.

Does a SimConnect reinstall work, as described above?

Peter

picnic
Posts: 36
Joined: Tue Apr 04, 2017 8:19 am

Re: 1.4.8 Crashes with a FileNotFound error

Postby picnic » Sat Feb 03, 2018 11:11 pm

As i said this is on a server with no FS so I've not installed SimConnect on it. 1.4.3 works would you expect different behaviour here with 1.4.8?

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: 1.4.8 Crashes with a FileNotFound error

Postby Peter » Sat Feb 03, 2018 11:58 pm

picnic wrote:As i said this is on a server with no FS so I've not installed SimConnect on it. 1.4.3 works would you expect different behaviour here with 1.4.8?


That's possibly related. Until very recently it was a requirement to have SimConnect installed otherwise JoinFS wouldn't run. However, I removed that link to allow it to run successfully. I wonder if something has broken that change?

Peter

aeronauta
Posts: 50
Joined: Sun Oct 09, 2016 4:42 am

Re: 1.4.8 Crashes with a FileNotFound error

Postby aeronauta » Sun Feb 04, 2018 5:48 am

Something has changed as I had the same crash and installed the simconnect .msi 10.0.61259.0 from P3D redist \FSX-SP2_Xpack and the crash is gone...win 10 latest fixes.( new system installed yesterday).

Jorge


Return to “Bugs”