incompatible IPv6 ?

Report problems with JoinFS.
fseindhoven
Posts: 17
Joined: Mon Feb 06, 2017 8:37 am
Location: Veldhoven
Contact:

incompatible IPv6 ?

Postby fseindhoven » Wed Oct 25, 2017 10:57 am

Hello Peter, version 1.2.8 on remote server; no error messages
Local version 1.2.8; From the local log file:
25-10-2017 12:11:21 Started
25-10-2017 12:11:21 Host is onbekend
25-10-2017 12:11:21 Er is een adres gebruikt dat niet compatibel is met het aangevraagde protocol, fe80::d159:1ec6:cad6:c3d9%12:6112
(an address is used which is not compatible with the requested protocol ...)
25-10-2017 12:11:22 Looking for simulator....
25-10-2017 12:11:41 Joining network
25-10-2017 12:11:41 Connected to network
25-10-2017 12:11:42 Added node 5292
25-10-2017 12:11:42 Connection established 5292
Error Message is repeated every 2 minutes in the log file
Where do I find this IPv6 address?
Favorites is empty, except my remote server address.
Or could it be an invalid IP as in the hubs.dat?
Does this event has anything to do with the visibility of players?
Thanks
Jan V

User avatar
Peter
Site Admin
Posts: 1457
Joined: Fri Sep 23, 2016 8:51 am

Re: incompatible IPv6 ?

Postby Peter » Wed Oct 25, 2017 11:48 am

Hi Jan,

JoinFS is only compatible with IPv4. It doesn't currently support IPv6. So, yes, you're right, somewhere along the line an IPv6 address has been used. I suspect you are right in thinking that it has come from a hub. Try closing JoinFS, renaming 'hubs.dat' to 'hubs_old.dat'. Then run JoinFS and it will re-populate your hub list, which should stop the error message.

I'm not seeing the error so it may be a hub that was temporarily online and had an incorrect address specified. I'll do some testing and see if I can reproduce it here. I may have to change the code so that it simply ignores any invalid addresses. At least that would stop generating the error in the log. It's not a problem in itself, it's just that an invalid address has been entered into the hub settings, which may have happened automatically. I'll have to investigate that.

No, it shouldn't affect your currently connected session at all.

Peter

fseindhoven
Posts: 17
Joined: Mon Feb 06, 2017 8:37 am
Location: Veldhoven
Contact:

Re: incompatible IPv6 ?

Postby fseindhoven » Wed Oct 25, 2017 12:37 pm

Thanks Peter,
i did already renamed the hubs.dat but that does not solve the issue.
What i can read in the .dat file is that every available server is using 1.2.8 except CyberAvia that apparently runs 1.2.9
198.27.64.165àÌñŸÕˆt?G?œŸO³ªùa™¢ÆÃ1.2.9 CyberAviaFirst french company First french companyLFTWT
For what it is worth ...
On behave of FSEINDHOVEN thanks for your continuous support.
Jan V

JarangMandi
Posts: 22
Joined: Thu Apr 13, 2017 10:20 am

Re: incompatible IPv6 ?

Postby JarangMandi » Sun Oct 29, 2017 4:47 pm

Peter,

I've been seeing the same errors as Jan and I just tried deleting the "hubs.dat" file like you suggest.

As soon as I restarted JoinFS I saw the errors that Jan describes in the logs. Turns out that the address that it's complaining about is that of the machine on which JoinFS is running. I get the same error message on my PC when I start up JoinFS on there except that it's complaining about the IPv6 address of the PC instead. The address it's complaining about in both instances is the "Link-local IPv6 Address" reported by ipconfig.

Interestingly, regardless of the port settings I have configured, it's complaining about port 6112. Even more interestingly, when I disable IPv6, I still get the error, except that it's complaining about address ::1:6112! Same problem when I disable IPv6 on every network adapter in my system!

Note that these errors are appearing even if I don't try to join a JoinFS network or create one of my own.

I'm presently running on Windows 10 Pro, version 1703, build 15063.674 - in case that's important.

Andy

User avatar
Peter
Site Admin
Posts: 1457
Joined: Fri Sep 23, 2016 8:51 am

Re: incompatible IPv6 ?

Postby Peter » Tue Oct 31, 2017 12:50 pm

Hi Jan, Andy

I think I may have found the problem. Try restarting your JoinFS and see if the error is still there. If it is, try closing JoinFS, deleting hubs.dat, and restarting JoinFS.

I know you have already tried this, but I have only just fixed an error in one of the initialization files on the website that I suspect was causing it.

Let me know how you get on.

Thanks,
Peter

JarangMandi
Posts: 22
Joined: Thu Apr 13, 2017 10:20 am

Re: incompatible IPv6 ?

Postby JarangMandi » Fri Nov 17, 2017 12:10 am

Sorry Peter, I've only just seen your update on this thread (note to self - turn on notifications when a reply is posted in future!)...

I'm not seeing the IPv6 errors in the log any more. Looks like whatever you've done has fixed it.

Andy


Return to “Bugs”