Hub status

Report problems with JoinFS.
Wood
Posts: 25
Joined: Wed Dec 07, 2016 6:50 pm

Hub status

Postby Wood » Fri Jan 27, 2017 3:56 am

Hi Peter

quick question regarding the displayed HUB /s We at VCW3 have our Hub running 24/7 and its been up for the few days since I restarted it. It seems every 2 or 3 days it removed itself or is not displayed in the Hub selection even though its up and online. Any idea's why this is happening.

hub status.png
hub status.png (37.6 KiB) Viewed 1854 times

wood

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: Hub status

Postby Peter » Fri Jan 27, 2017 9:51 am

Hi Wood,

Is your hub called "VCW3". I can't see it listed. Do you have port forwarding enabled for UDP on the right port number?

Peter

Wood
Posts: 25
Joined: Wed Dec 07, 2016 6:50 pm

Re: Hub status

Postby Wood » Fri Jan 27, 2017 1:49 pm

Hi Peter

Server is called Atlantic Fleet VCW3. Yes ports open as it should. From previous post it does display but only for a couple off days then for some reason is removed. If the Hub is running 24/7 and should be displayed. Correct?

As you can See it's displaying on the actual server when i bring up hubs.
server hub.png
server hub.png (91.4 KiB) Viewed 1835 times


But for some reason it is not being displayed to the clients.

Wood

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: Hub status

Postby Peter » Fri Jan 27, 2017 3:15 pm

Yes, there's definitely a problem there.

First of all, when you see your own hub in your list, it doesn't necessarily mean that everyone will be able to see it. A JoinFS hub will always show itself at the top of that list.

When you say it disappears after two days, is it disappearing from the top of its own list after running for two days?

I still haven't seen this server in my own list. Could you send me a PM with the address and port number for the server and I'll see if I can track down the problem.

Peter

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: Hub status

Postby Peter » Sat Jan 28, 2017 10:24 am

Found the bug, will be fixed in 1.1.5.

Thanks,
Peter

Wood
Posts: 25
Joined: Wed Dec 07, 2016 6:50 pm

Re: Hub status

Postby Wood » Wed Feb 01, 2017 12:59 am

Hi Peter.

Does this new stable version you released on the 28th have this issue fixed?

Wood

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: Hub status

Postby Peter » Wed Feb 01, 2017 10:25 am

No, it will be fixed in 1.1.5.

Peter

Wood
Posts: 25
Joined: Wed Dec 07, 2016 6:50 pm

Re: Hub status

Postby Wood » Wed Mar 01, 2017 5:16 pm

Hi Peter.

Hey we're still running into the hub not been seen in the hub area. Nothing has changed at except for updating to 1.6.

Here's an example. Getting another member setup with joinfs client for the first time. He was asked to go to views/hubs and should be able to see all hubs that are online. He could see everyone except for ours until he actually created a bookmark. Only then was he an able to see the our hub.

Wood

User avatar
Peter
Site Admin
Posts: 1459
Joined: Fri Sep 23, 2016 8:51 am

Re: Hub status

Postby Peter » Wed Mar 01, 2017 6:02 pm

Hi Wood,

There will be some delay while the hub information gets propagated around the network. The hub messages are only processed every two minutes, so it could be several minutes before you start to see changes. It's done that way so that it's very light on resources.

It's probably best not to use a hub if you're just meeting up with friends. That's what the bookmarks are designed for. Hubs are more of a permanent online meeting point that any pilot can join at any time.

Peter

Wood
Posts: 25
Joined: Wed Dec 07, 2016 6:50 pm

Re: Hub status

Postby Wood » Wed Mar 01, 2017 10:07 pm

That's exactly why we have the hub 24/7 so members can join and fly at there convience. So for us there is no other option then a hub.
Last edited by Wood on Wed Mar 01, 2017 10:09 pm, edited 1 time in total.


Return to “Bugs”