SIMCOM X Voice application

Suggestions, ideas and general discussion about JoinFS.
ATC Roo
Posts: 380
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Sun Sep 23, 2018 1:54 pm

I'll be releasing the first stable version sometime this week.
This version will support FSUIPC and selection of input/output audio devices.

ATC Roo
Posts: 380
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Fri Sep 28, 2018 9:54 pm

V0.1.00
Download here!

Image

I've not made it the stable release yet as I added a fair bit to this version and optimised a lot of the code.

Once people have confirmed there are no errors this will be the first stable version.

This version....
The main thing is a new installer.
This clears up all files on uninstall (unlike the previous installer).
I would advise uninstalling any older versions from add and remove programs before installing this new version.
Else this newer version will install alongside any previous versions.
Not an issue, but you don't need 2 versions.
After add and remove programs delete folders named Roo in C:\Program Files(x86) and C:\Users\YOUR NAME\AppData\Local
As the previous uninstaller won't remove those folders.

Added FSUIPC support.
So FS9 users can join in.
This should also work with XUIPC for Xplane users.
Latest XPUIPC can be found here.

And now with less hair than I started with.....
I've added the ability to choose your audio device.

Other changes include...
making the background sounds a little quieter so voice can be heard (useful for a voice app).
Adding a tick box to disable the background static noise.
Optimised the Distance funtion where a station goes quieter the further away the get.
Added miles from a station to update in the client window.


As always let me know the pros and cons.

I'm not planning on changing anything for a bit as it seemed to hold up well for me.

ATC Roo
Posts: 380
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Wed Oct 31, 2018 11:30 pm

I've found a few small issues with the recent testing.
That's what testing is for.

So there will be an update in the next couple of days.
I'll post it here shortly.

I've just added an update check into the version I'm working on at the moment.

Basically it'll pop up and ask you if you want to install the latest version, if you haven't already got it.

I'm also looking into ways to check if your UDP port is open correctly, which I noticed a few people having issues with and should also help.

At the moment there is a test frequency active on 122.800 in SIMCOM X mode, which will not need port 9988 open.

Feel free to test on this frequency.

If you wanted to test the group mode, use roo.servebeer.com in the IP box.
Again you will not need your port open for that either.

As always, please let me know the issues so I can fix them.

kc10b747fe
Posts: 10
Joined: Wed Mar 01, 2017 6:04 am

Re: SIMCOM X Voice application

Postby kc10b747fe » Thu Nov 01, 2018 9:08 am

Hey Roo,

I've been trying to use the SIMCOMX app V0.1.0.0, and I'm not sure what I am doing wrong, but I can't seem to get connected to another person using the app. We installed and initially had a problem on WIN 10 saying there was a problem with Visual C++ and it would not install. We tried installing the most current vc_redistx64, but that would not work. When using the 32 bit vc_redistx86 the app installed and we were able to configure with no issues.

We initially selected SCX mode. I turned on the power button and everything appears correct and green. I am able to see my name in the On Frequency Box and also the UNICOM Freq 122.800 in the Online ATC box. I've opened UDP port 9988 within my router, and also created a inbound and outbound rule in the Windows firewall for UDP 9988. The person I am trying to connect to has opened port 9988 on his router also. His SIMCOMX app shows green in SCX mode also. We are able to connect via JoinFS and see each other, but when we tune to the same freq, neither of our names shows up on the others list.

We tried Host Group Server both ways. In the server box the only thing that shows is Group Host, but I gave him the ip address that was listed on the config screen (which is the same one JoinFS is connected to) and tried to connect, and he received a message in the text box saying "check that the ip address is correct" and no connection was made. We also attempted having him as the Group Host and I received the same message. We also tried without SCX or Group Host selected and in the server box either localhost showed or 127.0.0.1. When inputting either ip address in the server box the power button would not turn on.

I also received an error about TeamSpeak which I did not have turned on and am not currently using. I attached a jpg that shows the error and also shows both our aircraft joined via JoinFS.

I know I must be missing something simple but any help is greatly appreciated.

Thanks for your hard work and support for the community. Looking forward to the update.

Tony J
Attachments
Screenshot 2018-10-31 12.47.31.jpg
Screenshot 2018-10-31 12.47.31.jpg (179.09 KiB) Viewed 204 times

ATC Roo
Posts: 380
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Thu Nov 01, 2018 1:25 pm

Thanks Tony.

The bad news is that the version you're using has an issue at the moment.
The issue does cause everything you describe above.
I noticed it during the testing the other day and I'm in the middle of writing a check for it which will fix it.

The good news is I should have the version I'm working on now, available very shortly.

I'm assuming that you have no issues with the auto switch feature (when tuning your SIM radio) and that the app is making noises at you to your headset or speakers?
Ie the sound card selection works?

It's just that you're not seeing anybody else in the channel with you?

Until the new version is out....
Have no tick boxes selected.
Pop roo.servebeer.com into the IP box and connect.
Have your friend do the same.

Does that work?

kc10b747fe
Posts: 10
Joined: Wed Mar 01, 2017 6:04 am

Re: SIMCOM X Voice application

Postby kc10b747fe » Thu Nov 01, 2018 4:18 pm

Roo,

Thanks for the quick response. What you said is correct. The auto switch works correctly, and I am receiving the TX and RX sound when keying my PTT. The audio card selection feature also checked out. However as stated above we are unable to connect, see or talk using any of the 3 methods. We'll try your work around and report back.

Thanks again,

Tony J

kc10b747fe
Posts: 10
Joined: Wed Mar 01, 2017 6:04 am

Re: SIMCOM X Voice application

Postby kc10b747fe » Thu Nov 01, 2018 8:01 pm

Roo,
I was able to connect and do some testing with my buddy for a couple of hours today. He was able to connect to your server. I on the other hand on my primary Win7 machine could not. I attached a screenshot of what everything looked like when I tried to turn the power button on.
Screenshot 2018-11-01 09.24.38.jpg
Screenshot 2018-11-01 09.24.38.jpg (128.12 KiB) Viewed 194 times
.

I tried a different computer and checked in the router that 9988 was open, checked with Port Forward Network Utilities, and that computer showed that the port was closed however I was able to connect to your server and we were able to test. Everything seemed to operate normally with an occasional stuck transmit and receive. If I transmitted, the TX light would turn red and stay red and he would see his RX light turn green, but then it would stick and would remain green. The callsign name in the On Freq box would turn red on his end and remain red. I would press my transmit button and the headphone icon in my systray would turn red and go out when released but the TX light would remain red. To clear we had to shut the app down (not just power off). Auto switching seemed to work well and we were able to go through different frequencies inside the airplane and transmit and receive very clearly. Manual switching also worked. We were also able to see each other in the On Freq Box, however sometimes it appeared that a 0 or 1 would attach to the end of each of our callsigns like a ghost user.

I shut down the computer I used to connect to your server, but when I brought it back up, I was unable to connect to your server. Again that particular computer showed that 9988 was closed originally but it still connected to the app. Don't know if I have a configuration issue, but JoinFS connected on both computers normally even though the 6112 port shows closed also.

hope the info helps

Tony J

ATC Roo
Posts: 380
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Thu Nov 01, 2018 11:56 pm

I've just uploaded v0.1.0.4

This has an update checker.
So if you fire it up one day and there is a newer version, It'll let you know.

Hopefully this has resolved a few issues.
Again it seems fine for me, but everybody doesn't have their PC setup the same as me.....

Let me know.
Last edited by ATC Roo on Fri Nov 02, 2018 8:59 pm, edited 2 times in total.

ATC Roo
Posts: 380
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Postby ATC Roo » Fri Nov 02, 2018 12:08 am

kc10b747fe wrote:Roo,
I was able to connect and do some testing with my buddy for a couple of hours today. He was able to connect to your server. I on the other hand on my primary Win7 machine could not. I attached a screenshot of what everything looked like when I tried to turn the power button on.Screenshot 2018-11-01 09.24.38.jpg.

I tried a different computer and checked in the router that 9988 was open, checked with Port Forward Network Utilities, and that computer showed that the port was closed however I was able to connect to your server and we were able to test. Everything seemed to operate normally with an occasional stuck transmit and receive. If I transmitted, the TX light would turn red and stay red and he would see his RX light turn green, but then it would stick and would remain green. The callsign name in the On Freq box would turn red on his end and remain red. I would press my transmit button and the headphone icon in my systray would turn red and go out when released but the TX light would remain red. To clear we had to shut the app down (not just power off). Auto switching seemed to work well and we were able to go through different frequencies inside the airplane and transmit and receive very clearly. Manual switching also worked. We were also able to see each other in the On Freq Box, however sometimes it appeared that a 0 or 1 would attach to the end of each of our callsigns like a ghost user.

I shut down the computer I used to connect to your server, but when I brought it back up, I was unable to connect to your server. Again that particular computer showed that 9988 was closed originally but it still connected to the app. Don't know if I have a configuration issue, but JoinFS connected on both computers normally even though the 6112 port shows closed also.

hope the info helps

Tony J



Thanks Tony.

The port doesn't need to be open to connect to roo.servebeer.com as open or not it would have connected.

I'll have to keep an eye on the stuck transmit, only seems to happen when a joystick button is set and is fine with keys for a ptt.
But most of us(me included) like to use a joystick button for our PTT.
If it does get stuck it SHOULD timeout after 15seconds. let me know....

0 or 1 is indeed a ghost user, a previous you which happens if you've rejoined a channel quicker that it took for OLD you to timeout.
I'm hoping I've just added something to correct that too, but it's bottom of the list at the moment.

And don't worry about port 6112 as I've noticed it doesn't seem to respond to ping requests.
Maybe Peter wrote it that way?

If you know your port is forwarded correctly then don't worry, as I said the version you were testing with was flawed.
This new version should correct that.

Thanks for the feedback, it's appreciated.

User avatar
Grumpy
Posts: 64
Joined: Mon Oct 10, 2016 2:30 am

Re: SIMCOM X Voice application

Postby Grumpy » Sun Nov 04, 2018 11:51 pm

Greetings, Roo

Josh and I are playing with SC-X

So far, we have met with limited success.

simcom X mode gives Josh this error
Image

We changed to using your server as a host.
Under NETWORK , nothing is ticked.
Under Simulator, FSX is ticked
The stuck TX and RX key is still there, changed to Left CTRL cured THAT.
Josh does NOT have FSX or any sim running on his laptop.
At this point, we have ONE working Freq, 119.400
When ever I try to change freqs, nothing. Nothing happens, still 119.400
It LOOKS like I have changed, but it LIES!!!
we have tried 123.450 NO!
122.800 NO

Apart from these few hangups, , veeery interesting.

Regards etc......

Bob


Return to “Discussion”