Newbie can't connect to simulator

Any questions regarding JoinFS.
John F
Posts: 12
Joined: Mon Dec 11, 2017 2:45 pm

Newbie can't connect to simulator

Postby John F » Mon Dec 11, 2017 2:58 pm

Using x Plane 11.10 and V1.4.3 JoinFS the "simulator" button refuses to connect to the sim and remains amber.

The XP plugin is installed, and the only other plugin enabled is XLua 1.0.0r 1 (whatever that is?)

joinFS.exe is excluded in McAfee.

JoinFS is installed in C;/JoinFS. Operating system is Windows 10

The XP aircraft is loaded up before trying to connect.

Any advice?

User avatar
Peter
Site Admin
Posts: 1133
Joined: Fri Sep 23, 2016 8:51 am

Re: Newbie can't connect to simulator

Postby Peter » Mon Dec 11, 2017 3:21 pm

Hi John,

Could you try following these guidelines from the manual, http://pmem.uk/joinfs/manual.html#xplane.

You need to load a flight in X-Plane before JoinFS will connect. I take it that you can see the JoinFS plugin listed in the X-Plane plugin menu?

Try checking the monitor windows in JoinFS, View|Monitor and see if there is an explanation there. Also check the <xplane>\Log.txt file and search in there for JoinFS. There should be some entries for it in the log.

Also make sure you have '127.0.0.1' entered in the JoinFS settings for the plugin address and that it is enable there as well.

Peter

John F
Posts: 12
Joined: Mon Dec 11, 2017 2:45 pm

Re: Newbie can't connect to simulator

Postby John F » Mon Dec 11, 2017 4:58 pm

Hi Peter,
Read the manuals and yes, Xplane in started first and plugin is enabled

Monitor window - What specifically am I looking for here? info below:
11/12/2017 16:39:24.963 Removed user 3668
11/12/2017 16:39:24.963 Delisting aircraft SB2C-4 : User=5391, Model=SB2C-4 Helldiver Yorktown
11/12/2017 16:39:24.963 Removed user 5391
11/12/2017 16:39:24.963 Delisting aircraft N683Y : User=2293, Model=Alabeo M20R Ovation N683Y
11/12/2017 16:39:24.963 Removed user 2293
11/12/2017 16:39:24.963 Removed user 47651
11/12/2017 16:39:24.963 Delisting aircraft LR-53 : User=1282, Model=Basler BT-67 - MSF Airways
11/12/2017 16:39:24.963 Removed user 1282
11/12/2017 16:39:24.963 Delisting aircraft N75CE : User=46502, Model=Christen Eagle II N75CE
11/12/2017 16:39:24.963 Removed user 46502
11/12/2017 16:39:24.963 Delisting aircraft 315221 : User=62220, Model=Douglas C-47 V3
11/12/2017 16:39:24.963 Removed user 62220
11/12/2017 16:39:24.963 Delisting aircraft N48MQ : User=30621, Model=Alabeo M20R Ovation N48MQ LITE
11/12/2017 16:39:24.963 Removed user 30621
11/12/2017 16:39:24.963 Delisting aircraft SP-BVI : User=48438, Model=AN2 SP-ASR
11/12/2017 16:39:24.963 Removed user 48438
11/12/2017 16:39:24.963 Joining network
11/12/2017 16:39:25.000 Connected to network
11/12/2017 16:39:25.000 Added user 5391
11/12/2017 16:39:25.000 Added user 62220
11/12/2017 16:39:25.000 Added user 30621
11/12/2017 16:39:25.000 Added user 48438
11/12/2017 16:39:25.000 Added user 1282
11/12/2017 16:39:25.000 Added user 2293
11/12/2017 16:39:25.000 Added user 46502
11/12/2017 16:39:25.000 Added user 3668
11/12/2017 16:39:25.031 Connection established 2293
11/12/2017 16:39:25.053 Listing aircraft 315221 : User=62220, Model=Douglas C-47 V3
11/12/2017 16:39:25.059 Connection established 1282
11/12/2017 16:39:25.081 Connection established 62220
11/12/2017 16:39:25.098 Listing aircraft LR-53 : User=1282, Model=Basler BT-67 - MSF Airways
11/12/2017 16:39:25.120 Listing aircraft N683Y : User=2293, Model=Alabeo M20R Ovation N683Y
11/12/2017 16:39:25.164 Connection established 3668
11/12/2017 16:39:25.168 Connection established 46502
11/12/2017 16:39:25.179 Listing aircraft SB2C-4 : User=5391, Model=SB2C-4 Helldiver Yorktown
11/12/2017 16:39:25.185 Connection established 5391
11/12/2017 16:39:25.211 Listing aircraft N75CE : User=46502, Model=Christen Eagle II N75CE
11/12/2017 16:39:25.228 Added user 47651
11/12/2017 16:39:25.305 Connection established 47651
11/12/2017 16:39:26.027 Connection established 48438
11/12/2017 16:39:26.027 Connection established 30621
11/12/2017 16:39:26.078 Listing aircraft N48MQ : User=30621, Model=Alabeo M20R Ovation N48MQ LITE
11/12/2017 16:39:30.142 Listing aircraft SP-BVI : User=48438, Model=AN2 SP-ASR
11/12/2017 16:40:17.123 Added user 19123
11/12/2017 16:40:17.177 Connection established 19123
11/12/2017 16:40:17.977 Listing aircraft NS-BZA : User=19123, Model=Feelthere A320 CFM Air France
11/12/2017 16:40:18.996 Delisting aircraft NS-BZA : User=19123, Model=Feelthere A320 CFM Air France
11/12/2017 16:40:18.996 Removed user 19123
11/12/2017 16:40:23.693 Added user 19123
11/12/2017 16:40:53.699 Removed user 19123

Log.txt file

Several references to join FS, but what exactly?

Should I be doing something in Xplane / configuration / Network?

127.0.0.1 is in JoinFS settings and the plugin enabled. I dont understand where these figures go in XPlane though???

Thanks for your help

User avatar
Peter
Site Admin
Posts: 1133
Joined: Fri Sep 23, 2016 8:51 am

Re: Newbie can't connect to simulator

Postby Peter » Mon Dec 11, 2017 6:56 pm

At the start of that log it should have said connected to X-Plane.

Let's start from the top.

1. Start JoinFS
2. Look at the bottom left of the main window and make sure it has version 1.4.3.
3. From the menu, select File|Settings, click on Install Plugin button and specify the root folder of your X-Plane installation.
4. In Windows file explorer, check that this file exists <xplane>\Resources\plugins\JoinFS\x64\win.xpl
5. Run X-Plane.
6. Select 'Resume Last Flight' or 'New Flight' and start a new flight.
7. Wait until loading has finished and you are in the 3D cockpit.
8. From the X-Plane menu, select Plugins|Plugin Admin|Enable/Disable.
9. There should be a JoinFS plugin listed and ticked.
10. In the main JoinFS window, if the simulator button is red, click it and it should turn green.

That ought to work.

Are you running 64 bit Windows 10?

Peter

John F
Posts: 12
Joined: Mon Dec 11, 2017 2:45 pm

Re: Newbie can't connect to simulator

Postby John F » Mon Dec 11, 2017 8:06 pm

Thanks Peter, that works! I am using x64 Win 10

Two last questions for you:-

1) Do you know if the online aircraft show up in Little Nav Map
2) Is it ok to leave my other plugins ticked?

User avatar
Peter
Site Admin
Posts: 1133
Joined: Fri Sep 23, 2016 8:51 am

Re: Newbie can't connect to simulator

Postby Peter » Mon Dec 11, 2017 8:53 pm

Great.

1. Yes, they should do. I gather from other users that add-on maps do show the network aircraft.

2. If you can see other network aircraft in X-Plane, then you're fine. If you're having trouble seeing them then you might need to disable one or more of the other plugins. So far I've heard that an IVAO plugin stops JoinFS from accessing the aircraft. I'll be adding a simulator message to indicate if this happens. The solution is quite easy - when using JoinFS, disable the other plugin, and when using IVAO, just enable it again. It's because only one plugin can access the aircraft at any time, so you just need to manage which plugin gets them.

Happy flying,
Peter

John F
Posts: 12
Joined: Mon Dec 11, 2017 2:45 pm

Re: Newbie can't connect to simulator

Postby John F » Wed Dec 13, 2017 10:21 am

Hi Peter,

I can now successfully get 2 greens on the start up screen. but after trying my first flight online with a friend last night we were unable to see each other’s plane at the airport. Some questions:-

1) We “joined a session” from view/hub/join. However I note in your manual the references to “Addresses” (encoded,IP, and domain) Do both of us need to do something with these, or should joinFS just work correctly when “joining a session” without doing something with these numbers?
2) In the aircraft screen which correctly showed mine and my friends plane, I noted that his position was 0.02M away from mine (next parking bay) Your manual states that, if my friend is within range of mine (which it is) then it should show as GREEN. It doesn’t. As far as I can tell this is the only inconsistency with the actual state and what your manual requires. Could you clarify please?
3) I am confused by the plane options. Can I fly with my friend in the identical XPlane plane? He has a different nickname of course, but the plane I/D is the same, and I wondered if this was relevant to our issue. The “broadcast” option in Aircaftview/Broadcast IS ticked.
4) In XPlane V11.10 there is the option to remove or add back AI planes. I am confused as to how this should be set up in Xplane. Do I need the default AI planes to be enabled or not? (I have no addon planes though my friend has)
5) As a general question for online flying, how does AI aircraft impact, if any, on the multiplayer aircraft you are trying to see?
6) For just wanting to fly with a friend, should I “Create a session” option instead? (I have read the “creating your own session” in Dan Sullivan’s guide but I can’t figure it out)
7) When I start joinFS, the opening screen “join” box seems to duplicate the “join” option in the Hub screen “join” so join is selected in 2 places? This has confused me

Thanks for your help

User avatar
Peter
Site Admin
Posts: 1133
Joined: Fri Sep 23, 2016 8:51 am

Re: Newbie can't connect to simulator

Postby Peter » Wed Dec 13, 2017 10:40 am

1) If you both joined the same hub, then you have both joined the same address. If you want to connect to your friend directly in your own session then your friend needs to press the 'Create' button and then you need to specify his 'Me' address in your 'Join' box and click join.
2) If the distance column for your friend's aircraft is no green then you won't see them in the simulator. If it's orange then something is not set up correctly.
3) You can both have the same nickname and callsign.
4) You need to add AI aircraft in the X-Plane configuration up to the number of network aircraft you want to see. If you add three AI aircraft you'll see up to three network aircraft. The AI aircraft will be allocated to the network aircraft in the session.
5) They won't impact on the multiplayer aircraft. They will be replaced by the multiplayer aircraft.
6) See 1), but that is unlikely to solve your current problem.
7) The opening screen join box allows you to enter the address of any other JoinFS client running over your LAN or the internet. The hub screen join button allows you to select and join a hub. Think of a hub as a 24/7 dedicated server.

It sounds as though you either haven't add any AI aircraft in X-Plane or you haven't installed the plugin in the right place. Try going through the steps for X-Plane setup in the manual. That should get you up and running. Also check the <xplane>\Log.txt for 'JoinFS' and the JoinFS monitor window for information.

Peter

John F
Posts: 12
Joined: Mon Dec 11, 2017 2:45 pm

Re: Newbie can't connect to simulator

Postby John F » Wed Dec 13, 2017 2:01 pm

Hi Peter,

This is a bit clearer thanks.
Currently loaded up joinFS and XP. Joined a hub and Network is green but - the log.txt files states:

JoinFS: Listening for the client on port 7472.
JoinFS: did not acquire plane.s

The Monitor states:

13/12/2017 13:46:50.441 Started
13/12/2017 13:46:50.464 SimConnect 10.0.61259.0 not installed.
13/12/2017 13:46:51.298 Connected to simulator
13/12/2017 13:46:51.298 X-Plane 11101.
13/12/2017 13:46:54.779 Listing aircraft N45XS : User=Me, ID=1000, Model=Laminar Research Baron_58
13/12/2017 13:47:17.721 Joining network
13/12/2017 13:47:17.876 Connected to network
13/12/2017 13:47:17.878 Added user 36069
13/12/2017 13:47:17.878 Added user 5839
13/12/2017 13:47:17.878 Added user 8980
13/12/2017 13:47:17.879 Added user 43132
13/12/2017 13:47:18.029 Connection established 5839
13/12/2017 13:47:18.201 Connection established 8980
13/12/2017 13:47:18.442 Added user 42560
13/12/2017 13:47:18.589 Connection established 42560
13/12/2017 13:47:18.783 Connection established 36069
13/12/2017 13:47:18.783 Connection established 43132
13/12/2017 13:47:19.021 Listing aircraft D-ABVM : User=36069, Model=PMDG 747-430 Lufthansa (D-ABVM | 2016)
13/12/2017 13:47:29.823 Connection established 43132
13/12/2017 13:47:40.858 Connection established 43132

Can you advise on this please?

User avatar
Peter
Site Admin
Posts: 1133
Joined: Fri Sep 23, 2016 8:51 am

Re: Newbie can't connect to simulator

Postby Peter » Wed Dec 13, 2017 2:57 pm

From the manual:

"You may need to disable other plugins that also try to access the X-Plane aircraft in order for JoinFS to work correctly. From the X-Plane plugin menu you can enable/disable plugins as required."

It looks like another plugin has taken exclusive access of the aircraft. You'll need to disable that plugin whenever you use JoinFS, and re-enable that plugin to use its functionality. It could be an IVAO or VATSIM plugin? You can disable them in the X-Plane plugin menu.

I'm sure that will solve it.

Peter


Return to “Queries”